NexusFi: Find Your Edge


Home Menu

 





Why does $TICK on a subgraph make an indicator disappear on a different subgraph?


Discussion in EasyLanguage Programming

Updated
    1. trending_up 1,496 views
    2. thumb_up 2 thanks given
    3. group 2 followers
    1. forum 4 posts
    2. attach_file 2 attachments




 
Search this Thread

Why does $TICK on a subgraph make an indicator disappear on a different subgraph?

  #1 (permalink)
 
GoldenRatio's Avatar
 GoldenRatio 
Philadelphia, PA
 
Experience: Advanced
Platform: Matlab, TradeStation
Trading: Stocks
Posts: 211 since Aug 2012
Thanks Given: 5,192
Thanks Received: 296

In Tradestation I have set up 3 subgraphs.

Subgraph 1 - I plot my VWAP indicator.
Subgraph 2 - I plot my VP that requires ELCollections.
Subgraph 3 - I wish to plot $TICK.

Whenever I add $Tick to the 3rd plot, the VP on subplot 2 disappears?



If I change the symbol in Subplot 3 to any equity symbol (i.e., MCD) VP on subplot 2 plots just fine?



Any idea why does adding $TICK to subplot 3 make the VP disappear in subplot 2?

Thank you to all in advance that reply!

Started this thread Reply With Quote

Can you help answer these questions
from other members on NexusFi?
Better Renko Gaps
The Elite Circle
MC PL editor upgrade
MultiCharts
Pivot Indicator like the old SwingTemp by Big Mike
NinjaTrader
REcommedations for programming help
Sierra Chart
How to apply profiles
Traders Hideout
 
Best Threads (Most Thanked)
in the last 7 days on NexusFi
Spoo-nalysis ES e-mini futures S&P 500
29 thanks
Just another trading journal: PA, Wyckoff & Trends
25 thanks
Tao te Trade: way of the WLD
24 thanks
Bigger Wins or Fewer Losses?
22 thanks
GFIs1 1 DAX trade per day journal
17 thanks
  #3 (permalink)
 ABCTG   is a Vendor
 
Posts: 2,434 since Apr 2013
Thanks Given: 481
Thanks Received: 1,627


GoldenRatio,

this is hard to tell from the images. Does it also happen with other studies or only with the volume profile?
One guess would be that it has something to do with the number of bars being different for the symbols (the $Tick continues when the other two symbols are closed). This might cause something unwanted in your code.

If you have the open code for the volume profile add print statements to it and look into what happens inside the code when only $Tick is updated.

Out of curiosity you could try a custom session (equal to the RTH) for the Tick, this should keep the profile on the chart in case the additional bars are causing the problems.

Regards,

ABCTG

Follow me on Twitter Reply With Quote
Thanked by:
  #4 (permalink)
 
GoldenRatio's Avatar
 GoldenRatio 
Philadelphia, PA
 
Experience: Advanced
Platform: Matlab, TradeStation
Trading: Stocks
Posts: 211 since Aug 2012
Thanks Given: 5,192
Thanks Received: 296

@ABCTG


ABCTG View Post
Does it also happen with other studies or only with the volume profile?

No, only with the volume profile.


ABCTG View Post
If you have the open code for the volume profile add print statements to it and look into what happens inside the code when only $Tick is updated.

Since the VP uses ELCOllections, I am wondering if it has something to do with that? Sorry, my EL programming skills are still not where the should be. I am not sure what to print to help detect the error? Can you help me come up with a print statement?


ABCTG View Post
You could try a custom session (equal to the RTH) for the Tick, this should keep the profile on the chart in case the additional bars are causing the problems.

Even with setting up a custom setting, the volume profile disappears as soon as I change the data in subplot3 to $TICK?

Started this thread Reply With Quote
  #5 (permalink)
 ABCTG   is a Vendor
 
Posts: 2,434 since Apr 2013
Thanks Given: 481
Thanks Received: 1,627

GoldenRatio,

I am afraid, but without knowing the code I can't make any recommendations for what to print - I can't guess the variable names used internally etc.. Your best bet might be to contact the developer of the indicator and have him/her look into the issue you are seeing.

Regards,

ABCTG



GoldenRatio View Post
Since the VP uses ELCOllections, I am wondering if it has something to do with that? Sorry, my EL programming skills are still not where the should be. I am not sure what to print to help detect the error? Can you help me come up with a print statement?


Follow me on Twitter Reply With Quote
Thanked by:




Last Updated on June 7, 2016


© 2024 NexusFi™, s.a., All Rights Reserved.
Av Ricardo J. Alfaro, Century Tower, Panama City, Panama, Ph: +507 833-9432 (Panama and Intl), +1 888-312-3001 (USA and Canada)
All information is for educational use only and is not investment advice. There is a substantial risk of loss in trading commodity futures, stocks, options and foreign exchange products. Past performance is not indicative of future results.
About Us - Contact Us - Site Rules, Acceptable Use, and Terms and Conditions - Privacy Policy - Downloads - Top
no new posts